Outreach Call Statuses Not Properly Updating

Incident Report for CipherHealth, Inc.

Resolved

This incident has been fully resolved.
Posted Nov 06, 2025 - 22:46 EST

Monitoring

We have finished applying the fix, and all Outreach statuses have been updated successfully. We will continue to monitor the system for any anomalies and provide further updates as necessary.
Posted Nov 06, 2025 - 22:25 EST

Identified

We've identified a solution to the call status issue and are working on implementing it.
Posted Nov 06, 2025 - 18:34 EST

Update

We are continuing to investigate this issue.
Posted Nov 06, 2025 - 17:04 EST

Investigating

We are currently investigating an issue where some Outreach calls today did not properly update their status within Evolve. We will provide another update as soon as we know more.
Posted Nov 06, 2025 - 15:58 EST
This incident affected: Evolve (CipherOutreach).