Call Statuses Not Updating Appropriately

Incident Report for CipherHealth, Inc.

Resolved

We've verified that the issue has been resolved, and we will continue our work to update statuses that were not updated during the time this issue was taking place.
Posted Nov 05, 2025 - 11:23 EST

Monitoring

The issue has been resolved and call statuses are updating appropriately for calls that are going out. We are working on updating the statuses of calls that were impacted by this issue.
Posted Nov 05, 2025 - 10:04 EST

Identified

We have identified an issue where Outreach call statuses are not updating appropriately. We'll share more information as we resolve this issue.
Posted Nov 05, 2025 - 09:38 EST
This incident affected: Evolve (CipherOutreach).