CipherRounds Experiencing Degraded Performance
Incident Report for CipherHealth, Inc.
Resolved
This incident has been resolved.
Posted May 30, 2024 - 18:01 EDT
Monitoring
We made some changes to how traffic is routed to certain servers (one of them was causing latency). Our internal testing indicates that this resolves the problem. We are currently validating the solution in its entirety and monitoring the situation.
Posted May 30, 2024 - 14:57 EDT
Investigating
We are aware of some performance issues that are affecting our CipherRounds application, and we are currently investigating.
Posted May 30, 2024 - 14:26 EDT
This incident affected: Evolve (CipherRounds App).