Insights Dashboard outage

Incident Report for CipherHealth, Inc.

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 03:25 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2025 - 02:53 EDT

Update

The issue has been identified and a fix is being rolled out.
Posted Jun 12, 2025 - 02:38 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 12, 2025 - 00:41 EDT

Investigating

We’re currently experiencing issues with our Insights dashboards due to an issue with a third-party data platform. Their team is investigating, and we’re monitoring the situation closely.

We’ll provide updates as soon as we have more information. Thank you for your patience.
Posted Jun 11, 2025 - 23:07 EDT
This incident affected: Evolve (Insights Dashboards).