Report Package Delays and Out-Of-Date Reporting Data
Incident Report for CipherHealth, Inc.
Resolved
This incident has been resolved.
Posted Feb 28, 2024 - 10:11 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 28, 2024 - 07:42 EST
Investigating
Some reports that were delivered this morning may contain data that is out of date. Some report deliveries this morning are delayed. We are investigating this issue.
Posted Feb 28, 2024 - 07:17 EST
This incident affected: Evolve (Insights Dashboards, Reports).