Evolve Application Sluggishness
Incident Report for CipherHealth, Inc.
Resolved
This incident has been resolved.
Posted Aug 20, 2024 - 16:45 EDT
Monitoring
We have increased our application's capacity and are seeing much better application latency now. We will continue to monitor.
Posted Aug 20, 2024 - 15:05 EDT
Identified
We believe we have identified the root cause of the application sluggishness. The issues appears related to application scale and we are increasing our capacity to address the impact.
Posted Aug 20, 2024 - 14:40 EDT
Investigating
We are currently investigating reports of application sluggishness. Users have reported experiencing delays and slower-than-normal response times when interacting with the application. Our technical team is actively working to identify the root cause of the issue and implement a solution as quickly as possible. We will provide updates as more information becomes available.
Posted Aug 20, 2024 - 14:12 EDT
This incident affected: Evolve (Evolve Application).