CipherRounds Login Failures
Incident Report for CipherHealth, Inc.
Resolved
This incident has been resolved.
Posted Apr 24, 2024 - 12:29 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2024 - 12:05 EDT
Identified
We are implementing a fix for this issue.
Posted Apr 24, 2024 - 10:41 EDT
Investigating
We are investigating an issue where users are not able to successfully log in to the CipherRounds iOS app.
Posted Apr 24, 2024 - 09:42 EDT
This incident affected: Evolve (CipherRounds App).