Disruption in Email Delivery

Incident Report for CipherHealth, Inc.

Resolved

The global email delivery issues have been mitigated. Our monitoring indicates that message flow has returned to normal and all CipherHealth services remain fully operational.
Posted Jan 23, 2026 - 01:27 EST

Monitoring

We are experiencing a disruption in email delivery service which may also impact 2-factor authentication login workflows. This appears to be related to a widespread third party service outages. We are monitoring and will keep you updated as it resolves.
Posted Jan 22, 2026 - 17:18 EST
This incident affected: Evolve (Email).