Delayed HL7 Message Processing

Incident Report for CipherHealth, Inc.

Resolved

This incident has been resolved.
Posted Jun 22, 2026 - 19:34 EDT

Monitoring

We identified the issue and applied a fix. Any queued up messages will process shortly. We will continue to monitor.
Posted Jun 22, 2026 - 19:05 EDT

Investigating

We are currently investigating an issue where some HL7 messages are queueing at the interface layer and not being processed. We will provide an update as soon as possible.
Posted Jun 22, 2026 - 18:16 EDT
This incident affected: Evolve (Data Feeds (HL7)).